OSPF Blog Content

OSPF - Open Shortest Path First

OSPF Explained Step By Step With Practicals From CCNA To CCIE Level

OSPF Design Limitation



OSPF does not have any limitation of routers like EIGRP and RIP has, it has a process to follow to have all area communicated.

        * If more than one area is configured, one area has to be Area 0.
        * All areas have to be connected to Area 0.
        * Area 0 must be contiguous.


Enabling OSPF


We can enable OSPF in two ways


Interface based Process Based
int f0/0 router ospf 1
ip ospf 1 area 0 network 0.0.0.0 0.0.0.0 area 0

Lets run OSPF process between 2 routers using Area-0, on R1 we will use interface based OSPF and on R2 we will run Process based


Router 1 Router 2
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 12.0.0.01 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#exit
R1(config)#interface range fastEthernet 0/0, loopback 0
R1(config-if-range)#ip ospf 1 area 0
R1(config-if-range)#exit
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 12.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 12.0.0.0 0.255.255.255 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#exit

Once the Parameters are checked, both routers will form the neighborship and we can see neighborship logs on CLI


Router 1 %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
Router 2 %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

Compare OSPFv2 and OSPFv3
        * Traditional OSPFv2 for IPv4
                router ospf process-id
                Transported over IPv4
        * Traditional OSPFv3 for IPv6 only
                ipv6 router ospf process-id
                Transported over IPv6
                Peering over IPv6 link-local addresses
        * New style OSPFv3 for IPv4 and IPv6 address families
                router ospfv3 process-id
                Transported over IPv6 (link-local addresses)
                No peering with traditional OSPFv2 routers

   ; 
image
image
image
image